🔸 معرفی کانال « امنیت در زیرساخت های صنعتی » به دوستان و همکاران خود از طریق لینک زیر
👇👇👇👇👇
👇👇👇👇👇
🙋♂️ سوال مطرح شده توسط یكي از اعضاي محترم كانال كه رئيس مهندسي يكي از پلنت هاي پتروشيمي است
❓ بهترين آنتي ويروس جهت استفاده در سيستم هاي كنترل صنعتي كدام است؟
🤔 همه اعضاي محترم كانال مي توانند پاسخ هاي خود را به ID
@Tajedinim
ارسال نموده تا پس از بررسي و تأييد در كانال منتشر گردد در غير اينصورت پاسخ اين سوال تا چند روز آينده داده خواهد شد.
@infrastructuresecurity
❓ بهترين آنتي ويروس جهت استفاده در سيستم هاي كنترل صنعتي كدام است؟
🤔 همه اعضاي محترم كانال مي توانند پاسخ هاي خود را به ID
@Tajedinim
ارسال نموده تا پس از بررسي و تأييد در كانال منتشر گردد در غير اينصورت پاسخ اين سوال تا چند روز آينده داده خواهد شد.
@infrastructuresecurity
معرفی استاندارد IEC 62351 جهت امن سازی پروتکل های سری TC 57 که در صنعت برق استفاده می شوند
@infrastructuresecurity
@infrastructuresecurity
استاندارد IEC 62351 توسط WG15 از IEC TC57 تهیه و تدوین شده است. این استاندارد جهت امن سازی پروتکل های سری TC57 ارائه گردیده است. همانطور که می دانیم پروتکل های سری TC57 شامل پروتکل هایی است که در صنایع مختلف بویژه صنعت برق و در ساختار سیستم های اسکادا مورد استفاده قرار می گیرند. این پروتکل ها عبارتند از :
1- پروتکل IEC 60870
2- پروتکل IEC 61850
3- پروتکل IEC 61970
4- پروتکل IEC 61968
استفاده از این استاندارد و پیاده سازی آن ویژگی ها و مزایای ذیل را به همراه خواهد داشت :
1- Authentication of Data Transfer through Digital Signatures
2- Ensuring only Authenticated Access
3- Prevention of eavesdropping
4- Prevention of playback and spoofing
5- Intrusion detection
استاندارد IEC 62351 شامل 11 بخش است که عبارتند از :
1- IEC 62351-1 — Introduction to the standard
2- IEC 62351-2 — Glossary of terms
3- IEC 62351-3 — Security for any profiles including TCP/IP.
- TLS Encryption
- Node Authentication by means of X.509 certificates
- Message Authentication
4- IEC 62351-4 — Security for any profiles including MMS (e.g., ICCP-based IEC 60870-6, IEC 61850, etc.).
- Authentication for MMS
- TLS (RFC 2246)is inserted between RFC 1006 & RFC 793 to provide transport layer security
5- IEC 62351-5 — Security for any profiles including IEC 60870-5 (e.g., DNP3 derivative)
- TLS for TCP/IP profiles and encryption for serial profiles.
6- IEC 62351-6 — Security for IEC 61850 profiles.
- VLAN use is made as mandatory for GOOSE
- RFC 2030 to be used for SNTP
7- IEC 62351-7 — Security through network and system management.
- Defines Management Information Base (MIBs) that are specific for the power industry, to handle network and system management through SNMP based methods.
8- IEC 62351-8 — Role-based access control.
- Covers the access control of users and automated agents to data objects in power systems by means of role-based access control (RBAC).
9- IEC 62351-9 — Key Management
- Describes the correct and safe usage of safety-critical parameters, e.g. passwords, encryption keys.
- Covers the whole life cycle of cryptographic information (enrollment, creation, distribution, installation, usage, storage and removal).
- Methods for algorithms using asymmetric cryptography
* Handling of digital certificates (public / private key)
* Setup of the PKI environment with X.509 certificates
* Certificate enrollment by means of SCEP / CMP
* Certificate revocation by means of CRL / OCSP
10- IEC 62351-10 — Security Architecture
- Explanation of security architectures for the entire IT infrastructure
- dentifying critical points of the communication architecture, e.g. substation control center, substation automation
- Appropriate mechanisms security requirements, e.g. data encryption, user authentication
- Applicability of well-proven standards from the IT domain, e.g. VPN tunnel, secure FTP, HTTPS
11- IEC 62351-11 — Security for XML Files
- Embedding of the original XML content into an XML container
- Date of issue and access control for XML data
- X.509 signature for authenticity of XML data
- Optional data encryption
@infrastructuresecurity
1- پروتکل IEC 60870
2- پروتکل IEC 61850
3- پروتکل IEC 61970
4- پروتکل IEC 61968
استفاده از این استاندارد و پیاده سازی آن ویژگی ها و مزایای ذیل را به همراه خواهد داشت :
1- Authentication of Data Transfer through Digital Signatures
2- Ensuring only Authenticated Access
3- Prevention of eavesdropping
4- Prevention of playback and spoofing
5- Intrusion detection
استاندارد IEC 62351 شامل 11 بخش است که عبارتند از :
1- IEC 62351-1 — Introduction to the standard
2- IEC 62351-2 — Glossary of terms
3- IEC 62351-3 — Security for any profiles including TCP/IP.
- TLS Encryption
- Node Authentication by means of X.509 certificates
- Message Authentication
4- IEC 62351-4 — Security for any profiles including MMS (e.g., ICCP-based IEC 60870-6, IEC 61850, etc.).
- Authentication for MMS
- TLS (RFC 2246)is inserted between RFC 1006 & RFC 793 to provide transport layer security
5- IEC 62351-5 — Security for any profiles including IEC 60870-5 (e.g., DNP3 derivative)
- TLS for TCP/IP profiles and encryption for serial profiles.
6- IEC 62351-6 — Security for IEC 61850 profiles.
- VLAN use is made as mandatory for GOOSE
- RFC 2030 to be used for SNTP
7- IEC 62351-7 — Security through network and system management.
- Defines Management Information Base (MIBs) that are specific for the power industry, to handle network and system management through SNMP based methods.
8- IEC 62351-8 — Role-based access control.
- Covers the access control of users and automated agents to data objects in power systems by means of role-based access control (RBAC).
9- IEC 62351-9 — Key Management
- Describes the correct and safe usage of safety-critical parameters, e.g. passwords, encryption keys.
- Covers the whole life cycle of cryptographic information (enrollment, creation, distribution, installation, usage, storage and removal).
- Methods for algorithms using asymmetric cryptography
* Handling of digital certificates (public / private key)
* Setup of the PKI environment with X.509 certificates
* Certificate enrollment by means of SCEP / CMP
* Certificate revocation by means of CRL / OCSP
10- IEC 62351-10 — Security Architecture
- Explanation of security architectures for the entire IT infrastructure
- dentifying critical points of the communication architecture, e.g. substation control center, substation automation
- Appropriate mechanisms security requirements, e.g. data encryption, user authentication
- Applicability of well-proven standards from the IT domain, e.g. VPN tunnel, secure FTP, HTTPS
11- IEC 62351-11 — Security for XML Files
- Embedding of the original XML content into an XML container
- Date of issue and access control for XML data
- X.509 signature for authenticity of XML data
- Optional data encryption
@infrastructuresecurity
🌸🌺🌸🌺🌸🌺
نوروز ، یادگار ماندگار یاران دیروز این دیار و پاسداشت پاکی ها ، نیکی ها و پهلوانی ها بر همه شما دوستان عزیز و اعضای محترم کانال پیشاپیش خجسته باد .
🌸🌺🌸🌺🌸🌺
با آرزوی بهترین ها برای شما و خانواده محترم در سال جدید
ارادتمند تاجدینی
@infrastructuresecurity
نوروز ، یادگار ماندگار یاران دیروز این دیار و پاسداشت پاکی ها ، نیکی ها و پهلوانی ها بر همه شما دوستان عزیز و اعضای محترم کانال پیشاپیش خجسته باد .
🌸🌺🌸🌺🌸🌺
با آرزوی بهترین ها برای شما و خانواده محترم در سال جدید
ارادتمند تاجدینی
@infrastructuresecurity
⚠️ قابل توجه کلیه عزیزان و متخصصین فعال در زیرساخت های صنعتی !!!
در حال حاضر می دانیم که در بسیاری از زیرساخت های صنعتی بویژه زیرساخت های حیاتی، حساس و مهم کشور دستورالعمل های مختلفی جهت ارتقا سطح امنیت سیستم های کامپیوتری و صنعتی ارائه گردیده و پیاده سازی شده است. هر چند این راهکارهای اعمال شده تا اندازه ای قابل قبول بوده و سطح امنیت را ارتقا بخشیده است ولی نمی توان صددرصد به آنها اکتفا کرد زیرا امروزه تکنیک های حملات سایبری جدیدی ارائه گردیده است که می تواند کلیه این راهکارها را دور زده و باعث بروز رخدادهای سایبری شوند.
✅ یک تیم تحقیقاتی از دانشگاه بنگورین اسراییل نشان داد که چگونه می توان فضای Air-Gap در مراکز صنعتی و حساس را بوسیله امواج ultrasonic دور زد و تمام اطلاعات را شنود کرد. برای انجام چنین حملاتی لازم است تنها در سیستم ایزوله صنعتی فقط یک اسپیکر یا یک هدفون معمولی حتی بدون میکروفون متصل باشد.
به این تکنیک جدید اصطلاحا MOSQUITO گفته می شود.
دوستان و اعضای محترم کانال به منظور کسب اطلاعات بیشتر در خصوص این تکنیک می توانند فایل زیر را مطالعه و کلیپ را مشاهده نمایند.
@infrastructuresecurity
در حال حاضر می دانیم که در بسیاری از زیرساخت های صنعتی بویژه زیرساخت های حیاتی، حساس و مهم کشور دستورالعمل های مختلفی جهت ارتقا سطح امنیت سیستم های کامپیوتری و صنعتی ارائه گردیده و پیاده سازی شده است. هر چند این راهکارهای اعمال شده تا اندازه ای قابل قبول بوده و سطح امنیت را ارتقا بخشیده است ولی نمی توان صددرصد به آنها اکتفا کرد زیرا امروزه تکنیک های حملات سایبری جدیدی ارائه گردیده است که می تواند کلیه این راهکارها را دور زده و باعث بروز رخدادهای سایبری شوند.
✅ یک تیم تحقیقاتی از دانشگاه بنگورین اسراییل نشان داد که چگونه می توان فضای Air-Gap در مراکز صنعتی و حساس را بوسیله امواج ultrasonic دور زد و تمام اطلاعات را شنود کرد. برای انجام چنین حملاتی لازم است تنها در سیستم ایزوله صنعتی فقط یک اسپیکر یا یک هدفون معمولی حتی بدون میکروفون متصل باشد.
به این تکنیک جدید اصطلاحا MOSQUITO گفته می شود.
دوستان و اعضای محترم کانال به منظور کسب اطلاعات بیشتر در خصوص این تکنیک می توانند فایل زیر را مطالعه و کلیپ را مشاهده نمایند.
@infrastructuresecurity
MOSQUITO Air Gap.pdf
2.9 MB
یک نمونه روش حمله سایبری بوسیله تکنیک MOSQUITO
@infrastructuresecurity
@infrastructuresecurity
بهترین آنتی ویروس برای سیستم های کنترل صنعتی ؟؟؟؟؟؟؟
@infrastructuresecurity
@infrastructuresecurity
🔶 پاسخ سوال « بهترین آنتی ویروس برای استفاده در سیستم های کنترل صنعتی کدام است؟ »
✔️ پاسخ ارائه شده توسط برخی از اعضای محترم کانال :
- McAfee
- Kaspersky
- ESET Node 32
از همه دوستانی که پاسخ های خود را ارسال نموده اند کمال تشکر را داریم
✅ پاسخ صحیح به شرح ذیل می باشد :
از آنجا که ساختار سیستم های کنترل صنعتی و IT دارای تفاوت هایی در بخش های مختلف آنها بوده لذا نمی توان هرگونه راه کار امنیتی قابل استفاده در IT را برای سیستم های کنترل صنعتی به کار برد زیرا احتمال بروز اختلال در اینگونه سیستم ها بسیار زیاد می باشد بنابراین حتما بایستی بهترین راهکار امنیتی سازگار با برند مورد استفاده پیاده سازی نمود.
امروزه کمپانی های مختلف از جمله Siemens، YOKOGAWA، ABB و ... نرم افزارها و سیستم های کنترلی را به بازار عرضه کرده اند و در بسیاری از زیرساخت های صنعتی کشور نیز مورد استفاده قرار گرفته اند؛ بنابراین راهکار امنیتی ارائه شده نیز باید سازگار با سیستم و برند مورد استفاده باشد.
در انتخاب آنتی ویروس نیز باید دقت نمود که کدام یک از آنتی ویروس های موجود در بازار دارای سازگاری با سیستم کنترل مورد نظر شما می باشد. به عنوان نمونه سیستم کنترل DeltaV از شرکت EMERSON با آنتی ویروس McAfee و Symantec سازگار می باشد.
⚠️ نکته بسیار بسیار مهم :
تحت هیچ شرایطی آنتی ویروس های معمول در بازار را نباید برای سیستم های کنترل صنعتی خریداری کرد و حتما بایستی از نسخه Industry آنها استفاده نمود. در این نسخه های ارائه شده تست ها و آزمایشات متعددی توسط کمپانی ها و همچنین مراکز بزرگ امنیتی انجام شده است و کاملا با سیستم کنترل مورد نظر سازگار هستند.
بنابراین برای خرید و نصب آنتی ویروس حتما به Industry بودن آنها توجه نمایید.
لازم به ذکر است پس از تهیه آنتی ویروس مناسب، تنظیمات و پیکربندی های خاصی نیز باید برای آنها انجام شود زیرا بدون انجام آن تنظیمات خاص، امکان بروز تداخل در سیستم وجود خواهد داشت.
👈 نتیجه گیری :
1- آنتی ویروس های معمول در سیستم های IT برای استفاده در سیستم های کنترل صنعتی مناسب نیستند.
2- هنگام خرید آنتی ویروس حتما به نوع برند سیستم کنترل باید توجه نمود.
3- حتما و حتما از نسخه Industry ارائه شده استفاده نمائید.
4- شرایط و نکات امنیتی مرتبط با خرید آنتی ویروس (چگونگی انتخاب، چگونگی خرید، نحوه تست، نحوه دسترسی و ... ) حتما در نظر گرفته شود.
5- پس از نصب نرم افزار آنتی ویروس حتما پیکربندی ها و تنظیمات ویژه مربوط به آنها با دقت انجام شود.
6- حتی الامکان از افرادی که دارای دانش امنیت و سیستم کنترل هستند استفاده شود.
در صورت نیاز به کسب اطلاعات بیشتر با ID
@Tajedinim
در ارتباط باشید.
@Infrastructuresecurity
✔️ پاسخ ارائه شده توسط برخی از اعضای محترم کانال :
- McAfee
- Kaspersky
- ESET Node 32
از همه دوستانی که پاسخ های خود را ارسال نموده اند کمال تشکر را داریم
✅ پاسخ صحیح به شرح ذیل می باشد :
از آنجا که ساختار سیستم های کنترل صنعتی و IT دارای تفاوت هایی در بخش های مختلف آنها بوده لذا نمی توان هرگونه راه کار امنیتی قابل استفاده در IT را برای سیستم های کنترل صنعتی به کار برد زیرا احتمال بروز اختلال در اینگونه سیستم ها بسیار زیاد می باشد بنابراین حتما بایستی بهترین راهکار امنیتی سازگار با برند مورد استفاده پیاده سازی نمود.
امروزه کمپانی های مختلف از جمله Siemens، YOKOGAWA، ABB و ... نرم افزارها و سیستم های کنترلی را به بازار عرضه کرده اند و در بسیاری از زیرساخت های صنعتی کشور نیز مورد استفاده قرار گرفته اند؛ بنابراین راهکار امنیتی ارائه شده نیز باید سازگار با سیستم و برند مورد استفاده باشد.
در انتخاب آنتی ویروس نیز باید دقت نمود که کدام یک از آنتی ویروس های موجود در بازار دارای سازگاری با سیستم کنترل مورد نظر شما می باشد. به عنوان نمونه سیستم کنترل DeltaV از شرکت EMERSON با آنتی ویروس McAfee و Symantec سازگار می باشد.
⚠️ نکته بسیار بسیار مهم :
تحت هیچ شرایطی آنتی ویروس های معمول در بازار را نباید برای سیستم های کنترل صنعتی خریداری کرد و حتما بایستی از نسخه Industry آنها استفاده نمود. در این نسخه های ارائه شده تست ها و آزمایشات متعددی توسط کمپانی ها و همچنین مراکز بزرگ امنیتی انجام شده است و کاملا با سیستم کنترل مورد نظر سازگار هستند.
بنابراین برای خرید و نصب آنتی ویروس حتما به Industry بودن آنها توجه نمایید.
لازم به ذکر است پس از تهیه آنتی ویروس مناسب، تنظیمات و پیکربندی های خاصی نیز باید برای آنها انجام شود زیرا بدون انجام آن تنظیمات خاص، امکان بروز تداخل در سیستم وجود خواهد داشت.
👈 نتیجه گیری :
1- آنتی ویروس های معمول در سیستم های IT برای استفاده در سیستم های کنترل صنعتی مناسب نیستند.
2- هنگام خرید آنتی ویروس حتما به نوع برند سیستم کنترل باید توجه نمود.
3- حتما و حتما از نسخه Industry ارائه شده استفاده نمائید.
4- شرایط و نکات امنیتی مرتبط با خرید آنتی ویروس (چگونگی انتخاب، چگونگی خرید، نحوه تست، نحوه دسترسی و ... ) حتما در نظر گرفته شود.
5- پس از نصب نرم افزار آنتی ویروس حتما پیکربندی ها و تنظیمات ویژه مربوط به آنها با دقت انجام شود.
6- حتی الامکان از افرادی که دارای دانش امنیت و سیستم کنترل هستند استفاده شود.
در صورت نیاز به کسب اطلاعات بیشتر با ID
@Tajedinim
در ارتباط باشید.
@Infrastructuresecurity
شناسایی نمونههای جدید جاسوسافزار شرکت Hacking Team
ایست هشدار میدهد که اخیرا نمونههای جدیدی از پرچمدار جاسوسافزار شرکت Hacking Team به نام سامانه کنترل از راه دور (RCS) ظاهر شده است، که با نسخههای مشاهدهشدهی پیشین تفاوت اندکی دارند.
آنچه که نشان میدهد که این نمونهها توسط خود توسعهدهندگان شرکت Hacking Team ساخته شده است، نسخهبندی نمونههای جدید است چرا که از آخرین شمارهی منتشر شده توسط این شرکت قبل از نفوذ، شروع میشود و یک الگوی مشابه پیروی میکند. ایست همچنین متوجه شد تغییرات معرفیشده در بهروزرسانیهای پس از افشاء با سبک کدنویسی شرکت Hacking Team همخوانی دارد و ارتباط عمیق بین این دو را نشان میدهد.
ایست میگوید: «تحقیق ما به ما اجازه میدهد که با اعتماد به نفس بالا ادعا کنیم که، با یک استثناء، نمونههای پس از افشاء که ما مورد تجزیه و تحلیل قرار دادیم، در واقع توسط توسعهدهندگان شرکت Hacking Team توسعه یافتهاند، و در نتیجهی سوء استفادهی عاملان مخرب دیگر از کد منبع افشاءشده ایجاد نشدهاند.»
لینک خبرhttps://u.asis.io/223
@infrastructuresecurity
ایست هشدار میدهد که اخیرا نمونههای جدیدی از پرچمدار جاسوسافزار شرکت Hacking Team به نام سامانه کنترل از راه دور (RCS) ظاهر شده است، که با نسخههای مشاهدهشدهی پیشین تفاوت اندکی دارند.
آنچه که نشان میدهد که این نمونهها توسط خود توسعهدهندگان شرکت Hacking Team ساخته شده است، نسخهبندی نمونههای جدید است چرا که از آخرین شمارهی منتشر شده توسط این شرکت قبل از نفوذ، شروع میشود و یک الگوی مشابه پیروی میکند. ایست همچنین متوجه شد تغییرات معرفیشده در بهروزرسانیهای پس از افشاء با سبک کدنویسی شرکت Hacking Team همخوانی دارد و ارتباط عمیق بین این دو را نشان میدهد.
ایست میگوید: «تحقیق ما به ما اجازه میدهد که با اعتماد به نفس بالا ادعا کنیم که، با یک استثناء، نمونههای پس از افشاء که ما مورد تجزیه و تحلیل قرار دادیم، در واقع توسط توسعهدهندگان شرکت Hacking Team توسعه یافتهاند، و در نتیجهی سوء استفادهی عاملان مخرب دیگر از کد منبع افشاءشده ایجاد نشدهاند.»
لینک خبرhttps://u.asis.io/223
@infrastructuresecurity
وبگاه اخبار امنیتی فنآوری اطلاعات و ارتباطات
شناسایی نمونههای جدید جاسوسافزار شرکت Hacking Team
ایست هشدار میدهد که اخیرا نمونههای جدیدی از پرچمدار جاسوسافزار شرکت Hacking Team به نام سامانه کنترل از راه دور (RCS) ظاهر شده است، که با نسخههای مشاهدهشدهی پیشین تفاوت اندکی دارند.
⚠️ قابل توجه کلیه پرسنل IT و ابزاردقیق زیرساخت های صنعتی
کلیه زیرساخت های صنعتی باید توجه داشته باشند که امروزه ابزارهای جاسوسی متنوعی را می توان در سیستم های IT و سیستم های کنترل صنعتی جاسازی نموده و مورد استفاده قرار داد. به عنوان نمونه می توان به سیم کارت جاسازی شده در کابل های USB اشاره کرد که برخی از از کارفرمایان عزیز زیرساخت های صنعتی به آن توجه ندارد. با استفاده از این ابزار می توان به بسیاری از اطلاعات محرمانه سیستم های IT و صنعتی دسترسی پیدا کرد.
اشکال زیر نمونه ای از این ابزارهای جاسوسی را نشان می دهد👇👇👇👇
@infrastructuresecurity
کلیه زیرساخت های صنعتی باید توجه داشته باشند که امروزه ابزارهای جاسوسی متنوعی را می توان در سیستم های IT و سیستم های کنترل صنعتی جاسازی نموده و مورد استفاده قرار داد. به عنوان نمونه می توان به سیم کارت جاسازی شده در کابل های USB اشاره کرد که برخی از از کارفرمایان عزیز زیرساخت های صنعتی به آن توجه ندارد. با استفاده از این ابزار می توان به بسیاری از اطلاعات محرمانه سیستم های IT و صنعتی دسترسی پیدا کرد.
اشکال زیر نمونه ای از این ابزارهای جاسوسی را نشان می دهد👇👇👇👇
@infrastructuresecurity
⚠️⚠️ آسیب پذیری در سیستم کنترل زیمنس
اخیرا Johannes Klick، Christian Pfahl، Martin Gebert و Lucas Jacob از تیم SCADACS دانشگاه Freie Universität Berlin آسیب پذیری DoS را در SIMATIC S7-300 CPU شناسایی کرده است. در همین راستا شرکت زیمنس به منظور کاهش آسیب پذیری گزارش شده در حال کار می باشد. لازم به ذکر است که این آسیب پذیری قابلیت بهره براداری از راه دور را دارد. آسیب پذیری به مهاجمان اجازه می دهد که حمله DoS را بر روی شبکه S7-300 CPU و بدون احراز هویت اجرا کنند. حمله در شرایط خاصی قابل اجراست. به منظور استفاده مجدد از تجهیز، نیاز است که سخت افزار تجهیز دوباره راه اندازی شود. تاثیراتی که این آسیب پذیری برای سازمان ها ایجاد می کند، برای هر سازمان کاملا منحصر به فرد بوده و به صورت case study باید مورد مطالعه قرار گیرد. بررسی تاثیرات به معماری شبکه، محیط عملیاتی و محصولات بستگی دارد.
👈 سابقه محصول آسیب پذیر
زیمنس یک شرکت بین المللی می باشد که دفتر مرکزی آن در مونیخ آلمان می باشد. SIMATIC S7-300 CPU به عنوان محصولات آسیب پذیر می باشند. این محصول به منظور کنترل پردازش در محیطهای صنعتی طراحی شده است. این محصولات به صورت جهانی در سراسر دنیا در حوزه هایی چون شیمیایی، انرژی، غذا و کشاورزی و سیستم های آب و فاضلاب به کار رفته است. شرکت زیمنس برآورد کرده است که این محصولات در ابتدا در ایالات متحده و اروپا و درصد کمی هم در آسیا مورد استفاده واقع شده است.
👈 محصولات آسیب پذیر
تمامی نسخه های خانواده SIMATIC S7-300 CPU
👈 بهره برداری از آسیب پذیری
تشریح آسیب پذیری به شرح زیر می باشد.
DENIAL-OF-SERVICE ATTACK
یک مهاجم از طریق ارسال پکت های خاص ایجاد شده به پورت 102/TCP (ISO-TSAP) یا از طریق پروتکل Profibus می تواند موجب شود تا تجهیز مورد هدف به حالت defect (نقص) برود. به منظور استفاده مجدد از تجهیز، نیاز است که سخت افزار تجهیز دوباره راه اندازی شود. شناسه CVE-2015-2177 به این آسیب پذیری اختصاص یافته است. این آسیب پذیری قابلیت بهره برداری از راه دور را داشته و بهره برداری موفق از این آسیب پذیری دشوار ارزیابی شده است.
👈 راه کار برطرف نمودن آسیب پذیری
شرکت زیمنس راه کارهای زیر را به منظور کاهش آسیبب پذیری گزارش شده به کاربران خود ارائه کرده است.
محافظت سطح 3 برای سیستم فراهم شود
محافظت سلولی را در سیستم ها پیاده شود
برای محافظت از ارتباط شبکه ای بین سلول ها از VPN استفاده شود
دفاع در عمق پیاده سازی شود
در همین راستا شرکت زیمنس در تلاش است تا نسخه های بروز رسانی شده ای از محصولات آسیب پذیر را ارائه کرده و به کاربران خود توصیه می کند تا این نسخه ها را دانلود و نصب کنند. در ادامه این شرکت از کاربران خود خواسته تا به آدرس های زیر مراجعه کنند.
http://www.siemens.com/cert/advisories
👈 در ادامه به منظور بهبود امنیت سایبری در سیستمهای کنترل صنعتی، پیشنهاد میشود که اقدامات زیر انجام شود:
* بازرسی امنیت فیزیکی، پیرامونی و محیطی
* ارزیابی سیاستهای امنیتی اعمال شده که باعث میشود آسیبپذیریهای بالقوه کاهش پیدا کند
* ارزیابی امنیتی سیستم های کنترل صنعتی
* وصله کردن آسیبپذیریها با توجه به گزارشهای تولید شده در سه بخش قبل
* امنسازی زیرساخت کنترل صنعتی با رویکرد دفاع در عمق
* استفاده از سنسور تشخیص نفوذ در بستر شبکه کنترل صنعتی
* استفاده از تجهیزات پیشگیرانه مانند Firewall و Data Diode
* پیادهسازی مرکز عملیات امنیت صنعتی/سایبری
* زمانی که اپراتورها نیاز به دسترسی از راه دور دارند، از VPN استفاده کنند (لازم به ذکر است که VPNها ممکن است آسیب پذیر باشند و باید به صورت پیوسته بروز شوند)
اخیرا Johannes Klick، Christian Pfahl، Martin Gebert و Lucas Jacob از تیم SCADACS دانشگاه Freie Universität Berlin آسیب پذیری DoS را در SIMATIC S7-300 CPU شناسایی کرده است. در همین راستا شرکت زیمنس به منظور کاهش آسیب پذیری گزارش شده در حال کار می باشد. لازم به ذکر است که این آسیب پذیری قابلیت بهره براداری از راه دور را دارد. آسیب پذیری به مهاجمان اجازه می دهد که حمله DoS را بر روی شبکه S7-300 CPU و بدون احراز هویت اجرا کنند. حمله در شرایط خاصی قابل اجراست. به منظور استفاده مجدد از تجهیز، نیاز است که سخت افزار تجهیز دوباره راه اندازی شود. تاثیراتی که این آسیب پذیری برای سازمان ها ایجاد می کند، برای هر سازمان کاملا منحصر به فرد بوده و به صورت case study باید مورد مطالعه قرار گیرد. بررسی تاثیرات به معماری شبکه، محیط عملیاتی و محصولات بستگی دارد.
👈 سابقه محصول آسیب پذیر
زیمنس یک شرکت بین المللی می باشد که دفتر مرکزی آن در مونیخ آلمان می باشد. SIMATIC S7-300 CPU به عنوان محصولات آسیب پذیر می باشند. این محصول به منظور کنترل پردازش در محیطهای صنعتی طراحی شده است. این محصولات به صورت جهانی در سراسر دنیا در حوزه هایی چون شیمیایی، انرژی، غذا و کشاورزی و سیستم های آب و فاضلاب به کار رفته است. شرکت زیمنس برآورد کرده است که این محصولات در ابتدا در ایالات متحده و اروپا و درصد کمی هم در آسیا مورد استفاده واقع شده است.
👈 محصولات آسیب پذیر
تمامی نسخه های خانواده SIMATIC S7-300 CPU
👈 بهره برداری از آسیب پذیری
تشریح آسیب پذیری به شرح زیر می باشد.
DENIAL-OF-SERVICE ATTACK
یک مهاجم از طریق ارسال پکت های خاص ایجاد شده به پورت 102/TCP (ISO-TSAP) یا از طریق پروتکل Profibus می تواند موجب شود تا تجهیز مورد هدف به حالت defect (نقص) برود. به منظور استفاده مجدد از تجهیز، نیاز است که سخت افزار تجهیز دوباره راه اندازی شود. شناسه CVE-2015-2177 به این آسیب پذیری اختصاص یافته است. این آسیب پذیری قابلیت بهره برداری از راه دور را داشته و بهره برداری موفق از این آسیب پذیری دشوار ارزیابی شده است.
👈 راه کار برطرف نمودن آسیب پذیری
شرکت زیمنس راه کارهای زیر را به منظور کاهش آسیبب پذیری گزارش شده به کاربران خود ارائه کرده است.
محافظت سطح 3 برای سیستم فراهم شود
محافظت سلولی را در سیستم ها پیاده شود
برای محافظت از ارتباط شبکه ای بین سلول ها از VPN استفاده شود
دفاع در عمق پیاده سازی شود
در همین راستا شرکت زیمنس در تلاش است تا نسخه های بروز رسانی شده ای از محصولات آسیب پذیر را ارائه کرده و به کاربران خود توصیه می کند تا این نسخه ها را دانلود و نصب کنند. در ادامه این شرکت از کاربران خود خواسته تا به آدرس های زیر مراجعه کنند.
http://www.siemens.com/cert/advisories
👈 در ادامه به منظور بهبود امنیت سایبری در سیستمهای کنترل صنعتی، پیشنهاد میشود که اقدامات زیر انجام شود:
* بازرسی امنیت فیزیکی، پیرامونی و محیطی
* ارزیابی سیاستهای امنیتی اعمال شده که باعث میشود آسیبپذیریهای بالقوه کاهش پیدا کند
* ارزیابی امنیتی سیستم های کنترل صنعتی
* وصله کردن آسیبپذیریها با توجه به گزارشهای تولید شده در سه بخش قبل
* امنسازی زیرساخت کنترل صنعتی با رویکرد دفاع در عمق
* استفاده از سنسور تشخیص نفوذ در بستر شبکه کنترل صنعتی
* استفاده از تجهیزات پیشگیرانه مانند Firewall و Data Diode
* پیادهسازی مرکز عملیات امنیت صنعتی/سایبری
* زمانی که اپراتورها نیاز به دسترسی از راه دور دارند، از VPN استفاده کنند (لازم به ذکر است که VPNها ممکن است آسیب پذیر باشند و باید به صورت پیوسته بروز شوند)
Forwarded from امنیت شبکه های صنعتی
🔸 معرفی کانال « امنیت در زیرساخت های صنعتی » به دوستان و همکاران خود از طریق لینک زیر
👇👇👇👇👇
👇👇👇👇👇
راهکار کامل امنیت سیستم های کنترل صنعتی توسط شرکت هانیول در یک نگاه
Honeywell Cyber security Slutions
@infrastructuresecurity
Honeywell Cyber security Slutions
@infrastructuresecurity
کلیه پرسنل زیرساخت های صنعتی مراقب باج افزار Crysis/Dharma باشند
@infrastructuresecurity
@infrastructuresecurity