CremaFinance Community Call #1 :First Step towards a Bigger Dream
We just had our first community call with our Crema fam last Wednesday on Dec.15th! We thought this was a great opportunity to both update…Continue reading on Medium »
Read more...
We just had our first community call with our Crema fam last Wednesday on Dec.15th! We thought this was a great opportunity to both update…Continue reading on Medium »
Read more...
How I earned $$$ by bypassing 2FA
Hi, I would like to share how I was able to bypass 2FA. This is a private program on Hackerone, so we will call it example.com.Continue reading on Medium »
Read more...
Hi, I would like to share how I was able to bypass 2FA. This is a private program on Hackerone, so we will call it example.com.Continue reading on Medium »
Read more...
hacking: security in practice
Advice
Pm if u can help me with a simple password recovery project
submitted by /u/CategoryInfamous8219
[link] [comments]
Advice
Pm if u can help me with a simple password recovery project
submitted by /u/CategoryInfamous8219
[link] [comments]
reddit
Advice
Pm if u can help me with a simple password recovery project
CremaFinance Community Call #1 :First Step towards a Bigger Dream
https://medium.com/@Crema.finance/cremafinance-community-call-1-first-step-towards-a-bigger-dream-4b1a63daab3?source=rss------bug_bounty-5
https://medium.com/@Crema.finance/cremafinance-community-call-1-first-step-towards-a-bigger-dream-4b1a63daab3?source=rss------bug_bounty-5
We just had our first community call with our Crema fam last Wednesday on Dec.15th! We thought this was a great opportunity to both update…Continue reading on Medium » (https://medium.com/@Crema.finance/cremafinance-community-call-1-first-step-towards-a-bigger-dream-4b1a63daab3?source=rss------bug_bounty-5)
Hacking Articles Tips Tricks Videos Tutorials
Photo
Black Hat Ethical Hacking
Microsoft warns of easy Windows domain takeover via Active Directory bugs
https://www.blackhatethicalhacking.com/wp-content/uploads/2021/08/Untitled-design-2-1.png Microsoft warns of easy Windows domain takeover via Active Directory bugsPost Views: 127 https://www.blackhatethicalhacking.com/wp-content/uploads/2021/08/BECOME-A-PATRON-AND-UNLOCK-EXCLUSIVE-VIDEOS-1.png Reading Time: 1 Minute
Microsoft warned customers today to patch two Active Directory domain service privilege escalation security flaws that, when combined, allow attackers to easily takeover Windows domains.
The company released security updates to address the two security vulnerabilities (tracked as CVE-2021-42287 and CVE-2021-42278 and reported by Andrew Bartlett of Catalyst IT) during the November 2021 Patch Tuesday.
Redmond’s warning to immediately patch the two bugs — both allowing attackers to impersonate domain controllers — comes after a proof-of-concept (PoC) tool that can leverage these vulnerabilities was shared on Twitter and GitHub on December 11.
“When combining these two vulnerabilities, an attacker can create a straightforward path to a Domain Admin user in an Active Directory environment that hasn’t applied these new updates,” Microsoft explains in an advisory published today.
“This escalation attack allows attackers to easily elevate their privilege to that of a Domain Admin once they compromise a regular user in the domain.
“As always, we strongly advise deploying the latest patches on the domain controllers as soon as possible.”
See Also: Complete Offensive Security and Ethical Hacking Course
Windows admins are urged to update devices exposed to attacks using the steps and information detailed in the following knowledgebase articles: KB5008102, KB5008380, KB5008602.
Researchers who tested the PoC stated that they were able to easily use the tool to escalate privileges from standard Active Directory user to a Domain Admin in default configurations.
https://www.bleepstatic.com/images/news/u/1109292/2021/CVE-2021-42278_exploit_tool.jpg
<figcaptionCVE-2021-42278 and CVE-2021-42287 exploit tool in action (H*s*m)
See Also: Hackers start pushing malware in worldwide Log4Shell attacks How to detect exploitation, signs of compromiseMicrosoft has also shared detailed guidance on detecting signs of exploitation in your environment and identifying potentially compromised servers using Defender for Identity advanced hunting query that looks for abnormal device name changes.
The step-by-step guide requires defenders to:
1. The sAMAccountName change is based on event 4662. Please make sure to enable it on the domain controller to catch such activities. Learn more of how to do it here
2. Open Microsoft 365 Defender and navigate to Advanced Hunting.
3. Copy the following query (which is also available in the Microsoft 365 Defender GitHub Advanced Hunting query):
5. Run the query and analyze the results which contain the affected devices. You can use Windows Event 4741 to find the creator of these machines if they were newly created
6. We recommend investigating these co[...]
Microsoft warns of easy Windows domain takeover via Active Directory bugs
https://www.blackhatethicalhacking.com/wp-content/uploads/2021/08/Untitled-design-2-1.png Microsoft warns of easy Windows domain takeover via Active Directory bugsPost Views: 127 https://www.blackhatethicalhacking.com/wp-content/uploads/2021/08/BECOME-A-PATRON-AND-UNLOCK-EXCLUSIVE-VIDEOS-1.png Reading Time: 1 Minute
Microsoft warned customers today to patch two Active Directory domain service privilege escalation security flaws that, when combined, allow attackers to easily takeover Windows domains.
The company released security updates to address the two security vulnerabilities (tracked as CVE-2021-42287 and CVE-2021-42278 and reported by Andrew Bartlett of Catalyst IT) during the November 2021 Patch Tuesday.
Redmond’s warning to immediately patch the two bugs — both allowing attackers to impersonate domain controllers — comes after a proof-of-concept (PoC) tool that can leverage these vulnerabilities was shared on Twitter and GitHub on December 11.
“When combining these two vulnerabilities, an attacker can create a straightforward path to a Domain Admin user in an Active Directory environment that hasn’t applied these new updates,” Microsoft explains in an advisory published today.
“This escalation attack allows attackers to easily elevate their privilege to that of a Domain Admin once they compromise a regular user in the domain.
“As always, we strongly advise deploying the latest patches on the domain controllers as soon as possible.”
See Also: Complete Offensive Security and Ethical Hacking Course
Windows admins are urged to update devices exposed to attacks using the steps and information detailed in the following knowledgebase articles: KB5008102, KB5008380, KB5008602.
Researchers who tested the PoC stated that they were able to easily use the tool to escalate privileges from standard Active Directory user to a Domain Admin in default configurations.
https://www.bleepstatic.com/images/news/u/1109292/2021/CVE-2021-42278_exploit_tool.jpg
<figcaptionCVE-2021-42278 and CVE-2021-42287 exploit tool in action (H*s*m)
See Also: Hackers start pushing malware in worldwide Log4Shell attacks How to detect exploitation, signs of compromiseMicrosoft has also shared detailed guidance on detecting signs of exploitation in your environment and identifying potentially compromised servers using Defender for Identity advanced hunting query that looks for abnormal device name changes.
The step-by-step guide requires defenders to:
1. The sAMAccountName change is based on event 4662. Please make sure to enable it on the domain controller to catch such activities. Learn more of how to do it here
2. Open Microsoft 365 Defender and navigate to Advanced Hunting.
3. Copy the following query (which is also available in the Microsoft 365 Defender GitHub Advanced Hunting query):
IdentityDirectoryEvents
| where Timestamp > ago(1d)
| where ActionType == "SAM Account Name changed"
| extend FROMSAM = parse_json(AdditionalFields)['FROM SAM Account Name']
| extend TOSAM = parse_json(AdditionalFields)['TO SAM Account Name']
| where (FROMSAM has "$" and TOSAM !has "$")
or TOSAM in ("DC1", "DC2", "DC3", "DC4") // DC Names in the org
| project Timestamp, Application, ActionType, TargetDeviceName, FROMSAM, TOSAM, ReportId, AdditionalFields4. Replace the marked area with the naming convention of your domain controllers5. Run the query and analyze the results which contain the affected devices. You can use Windows Event 4741 to find the creator of these machines if they were newly created
6. We recommend investigating these co[...]
Hacking Articles Tips Tricks Videos Tutorials
Black Hat Ethical Hacking Microsoft warns of easy Windows domain takeover via Active Directory bugs https://www.blackhatethicalhacking.com/wp-content/uploads/2021/08/Untitled-design-2-1.png Microsoft warns of easy Windows domain takeover via Active Directory…
mpromised computers and determining that they haven’t been weaponized.
See Also: Offensive Security Tool: log4j-scan “Our research team continues its effort in creating more ways to detect these vulnerabilities, either with queries or out-of-the-box detections,” Microsoft added.
See Also: Hacking stories – Rafael Núñez (aka RaFa), hacking NASA with the hacking group: World of Hell
Source: www.bleepingcomputer.com (Click Link)https://www.blackhatethicalhacking.com/wp-content/uploads/2021/11/Untitled-design.png Recent News* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/ezgif.com-gif-maker-4-90x90.jpg TellYouThePass ransomware revived in Linux, Windows Log4j attacks1 day ago
* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/ezgif.com-gif-maker-3-1-90x90.jpg Log4j attackers switch to injecting Monero miners via RMI4 days ago
* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/Hackers-Using-Malicious-IIS-Server-Module-to-Steal-Microsoft-Exchange-560x380-1-90x90.jpg Hackers steal Microsoft Exchange credentials using IIS module5 days ago
* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/how-ransomware-works-1024x535-1-90x90.png New ransomware now being deployed in Log4Shell attacks6 days ago
* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/0d73-article-201111-ubuntu-90x90.jpg Attackers can get root by crashing Ubuntu’s AccountsService1 week ago
* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/frame_2_delay-0.5s-90x90.jpg Hackers start pushing malware in worldwide Log4Shell attacks1 week ago
* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/ezgif.com-gif-maker-3-90x90.jpg Malicious Notepad++ installers push StrongPity malware2 weeks ago
* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/Kali-Linux-2021.4-Released-90x90.png Kali Linux 2021.4 Released – New Themes and Tools, name-that-hash, truffleHog, S3Scanner, KDE Plasma 5.232 weeks ago
* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/cover_image_1598944248.jpg.760x400_q85_crop_upscale-90x90.jpg Hackers infect random WordPress plugins to steal credit cards2 weeks ago
* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/ezgif.com-gif-maker-2-90x90.jpg 27 flaws in USB-over-network SDK affect millions of cloud users2 weeks ago
The post Microsoft warns of easy Windows domain takeover via Active Directory bugs first appeared on Black Hat Ethical Hacking.
See Also: Offensive Security Tool: log4j-scan “Our research team continues its effort in creating more ways to detect these vulnerabilities, either with queries or out-of-the-box detections,” Microsoft added.
See Also: Hacking stories – Rafael Núñez (aka RaFa), hacking NASA with the hacking group: World of Hell
Source: www.bleepingcomputer.com (Click Link)https://www.blackhatethicalhacking.com/wp-content/uploads/2021/11/Untitled-design.png Recent News* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/ezgif.com-gif-maker-4-90x90.jpg TellYouThePass ransomware revived in Linux, Windows Log4j attacks1 day ago
* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/ezgif.com-gif-maker-3-1-90x90.jpg Log4j attackers switch to injecting Monero miners via RMI4 days ago
* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/Hackers-Using-Malicious-IIS-Server-Module-to-Steal-Microsoft-Exchange-560x380-1-90x90.jpg Hackers steal Microsoft Exchange credentials using IIS module5 days ago
* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/how-ransomware-works-1024x535-1-90x90.png New ransomware now being deployed in Log4Shell attacks6 days ago
* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/0d73-article-201111-ubuntu-90x90.jpg Attackers can get root by crashing Ubuntu’s AccountsService1 week ago
* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/frame_2_delay-0.5s-90x90.jpg Hackers start pushing malware in worldwide Log4Shell attacks1 week ago
* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/ezgif.com-gif-maker-3-90x90.jpg Malicious Notepad++ installers push StrongPity malware2 weeks ago
* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/Kali-Linux-2021.4-Released-90x90.png Kali Linux 2021.4 Released – New Themes and Tools, name-that-hash, truffleHog, S3Scanner, KDE Plasma 5.232 weeks ago
* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/cover_image_1598944248.jpg.760x400_q85_crop_upscale-90x90.jpg Hackers infect random WordPress plugins to steal credit cards2 weeks ago
* https://www.blackhatethicalhacking.com/wp-content/uploads/2021/12/ezgif.com-gif-maker-2-90x90.jpg 27 flaws in USB-over-network SDK affect millions of cloud users2 weeks ago
The post Microsoft warns of easy Windows domain takeover via Active Directory bugs first appeared on Black Hat Ethical Hacking.
How I earned $$$ by bypassing 2FA
https://medium.com/@mohamedtaha_42562/how-i-earned-by-bypassing-2fa-b5487942a86d?source=rss------bug_bounty-5
https://medium.com/@mohamedtaha_42562/how-i-earned-by-bypassing-2fa-b5487942a86d?source=rss------bug_bounty-5
Hi, I would like to share how I was able to bypass 2FA. This is a private program on Hackerone, so we will call it example.com.Continue reading on Medium » (https://medium.com/@mohamedtaha_42562/how-i-earned-by-bypassing-2fa-b5487942a86d?source=rss------bug_bounty-5)
Log4j Vulnerability Explanation In Details
https://infosecwriteups.com/log4j-vulnerability-explanation-in-details-73f7556c5ff1?source=rss------bug_bounty-5
https://infosecwriteups.com/log4j-vulnerability-explanation-in-details-73f7556c5ff1?source=rss------bug_bounty-5
Everything you need to know about log4j vulnerability as a hacker !Continue reading on InfoSec Write-ups » (https://infosecwriteups.com/log4j-vulnerability-explanation-in-details-73f7556c5ff1?source=rss------bug_bounty-5)
Powershell .Net Assembly loader for the [CVE-2021-42287 - CVE-2021-42278] Scanner & Exploiter
https://www.reddit.com/r/redteamsec/comments/rlc046/powershell_net_assembly_loader_for_the/
submitted by /u/v1brio (https://www.reddit.com/user/v1brio)
[link] (https://github.com/ricardojba/Invoke-noPac) [comments] (https://www.reddit.com/r/redteamsec/comments/rlc046/powershell_net_assembly_loader_for_the/)
https://www.reddit.com/r/redteamsec/comments/rlc046/powershell_net_assembly_loader_for_the/
submitted by /u/v1brio (https://www.reddit.com/user/v1brio)
[link] (https://github.com/ricardojba/Invoke-noPac) [comments] (https://www.reddit.com/r/redteamsec/comments/rlc046/powershell_net_assembly_loader_for_the/)
CVE-2021-42287/CVE-2021-42278 Scanner & Exploiter Fork with some improvements
https://www.reddit.com/r/redteamsec/comments/rlc0ve/cve202142287cve202142278_scanner_exploiter_fork/
submitted by /u/v1brio (https://www.reddit.com/user/v1brio)
[link] (https://github.com/ricardojba/noPac) [comments] (https://www.reddit.com/r/redteamsec/comments/rlc0ve/cve202142287cve202142278_scanner_exploiter_fork/)
https://www.reddit.com/r/redteamsec/comments/rlc0ve/cve202142287cve202142278_scanner_exploiter_fork/
submitted by /u/v1brio (https://www.reddit.com/user/v1brio)
[link] (https://github.com/ricardojba/noPac) [comments] (https://www.reddit.com/r/redteamsec/comments/rlc0ve/cve202142287cve202142278_scanner_exploiter_fork/)
Mesh-Kridik - An Open-Source Security Checker That Performs Various Security Checks On A Kubernetes Cluster With Istio Service Mesh And Is Leveraged By OPA (Open Policy Agent) To Enforce Security Rules
http://www.kitploit.com/2021/12/mesh-kridik-open-source-security.html
http://www.kitploit.com/2021/12/mesh-kridik-open-source-security.html
Enhance your Kubernetes (https://www.kitploit.com/search/label/Kubernetes) service mesh security !!mesh-kridik is an open-source security checker that performs various security checks on a Kubernetes cluster with istio service mesh and outputs a security report.The security checks tests are the full implementation of istio security best practices (https://istio.io/latest/docs/ops/best-practices/security/)
The security checks performed on a Kubernetes cluster with istio service mesh and is leveraged by OPA (Open Policy Agent) to enforce security rules, and the output audit report includes: the root cause of the security issue and proposed remediation for the security issue.
The security checks performed on a Kubernetes cluster with istio service mesh and is leveraged by OPA (Open Policy Agent) to enforce security rules, and the output audit report includes: the root cause of the security issue and proposed remediation for the security issue.